Outlook 2010 won't connect to the imap server

Use this forum to post questions relating to WinGate, feature requests, technical or configuration problems

Moderator: Qbik Staff

Outlook 2010 won't connect to the imap server

Postby M76 » Feb 11 11 6:34 am

Hi

I've recently upgraded to office 2010 and outlook 2010 can't connect to the imap server, it says that it cannot find a suitable authorization protocol that is supported by the computer. If I allow unsecure connections then it connects, but does nothing and still gives a timeout error after the timeout period is over.

What can i do?

I turned on debug logging and this is what it shows when I try to connect from outlook:

Code: Select all
02/06/11 14:12:29   192.168.0.5   mumia   0000045698   Debug:   S:=> * OK WinGate IMAP4rev1 service ready
02/06/11 14:12:29   192.168.0.5   mumia   0000045698   Debug:   C:<= 0ci3 CAPABILITY
02/06/11 14:12:29   192.168.0.5   mumia   0000045698   Debug:   S:=> * CAPABILITY IMAP4 IMAP4rev1 UNSELECT LITERAL+ ID UIDPLUS IDLE AUTH=CRAM-MD5 LOGIN
02/06/11 14:12:29   192.168.0.5   mumia   0000045698   Debug:   S:=> 0ci3 OK CAPABILITY command completed
02/06/11 14:12:29   192.168.0.5   mumia   0000045698   Traffic    160   17   0   0   0s
M76
 
Posts: 24
Joined: May 12 06 7:59 am

Re: Outlook 2010 won't connect to the imap server

Postby adrien » Feb 11 11 7:09 am

Hi

since you're using the WinGate user database, the only available options are LOGIN and CRAM-MD5.

LOGIN is the default plaintext / insecure option.

Maybe they dropped support for CRAM-MD5 with Outlook 2010 (if it ever supported it)? Do you have any debug logs of previous Outlook clients?

Are you on an Active Directory? What OS hosts the AD, and what OS is the client running?

Regards

Adrien
adrien
Qbik Staff
 
Posts: 4844
Joined: Sep 03 03 2:54 pm
Location: Auckland

Re: Outlook 2010 won't connect to the imap server

Postby M76 » Feb 13 11 5:47 am

I only used outlook express prevously, that worked, but outlook express is an entirely different application than outlook, windows live mail is the successor of outlook express.

No active directory, outlook runs on windows 7 64bit enterprise. wingate is on a computer with xp pro sp3 x86
M76
 
Posts: 24
Joined: May 12 06 7:59 am

Re: Outlook 2010 won't connect to the imap server

Postby adrien » Feb 15 11 12:10 pm

Hi

From what I can find trawling the net (many complaints from outlook users) CRAM-MD5 support in Outlook has been broken for quite a long time.

Strange, since it's really quite a simple method. Anyway that leaves only a couple of options.

1. Don't use CRAM-MD5 (e.g. use an SSL connection to the IMAP server on another port).
2. Try WinGate 7. WinGate 7 supports NTLM even using the WinGate user database.

I have to say also I've found every time I looked at Outlook for IMAP it has to be one of the worst IMAP implementations ever. Can the user run Thunderbird instead (not fantastic, but miles better).

Regards

Adrien
adrien
Qbik Staff
 
Posts: 4844
Joined: Sep 03 03 2:54 pm
Location: Auckland

Re: Outlook 2010 won't connect to the imap server

Postby rboynton » Feb 17 11 5:26 am

adrien wrote: I have to say also I've found every time I looked at Outlook for IMAP it has to be one of the worst IMAP implementations ever.


Now, now... Must not step on sacred ground. You might cause an earthquake which would shake those ivory towers.
...Rick
rboynton
Senior Member
 
Posts: 156
Joined: Jun 15 07 2:09 am
Location: Boerne, Texas


Return to WinGate

Who is online

Users browsing this forum: Bing [Bot] and 1 guest