How to set up proxy server properly

Use this forum to post questions relating to WinGate, feature requests, technical or configuration problems

Moderator: Qbik Staff

How to set up proxy server properly

Postby kao » Sep 13 17 7:51 pm

Hello,

I used your software to set up my VPS server as a proxy server. However, I am not that tech-friendly so I may have some questions. I though it would be the best to post them here.

So I set up SOCKS proxy like this:
Image

Is this a good setup or should I change anything?

Because my issue here, is that port 1080 is open and the websites are able to see that and I do not want websites to know that I am using proxy.
Image

My question is simple - how to set up/configure the wingate, so websites would not be able to see that I am using a proxy (no open ports would be shown)?

I also tried to install HTTP proxy service, but unsuccessfully, if someone explained how to do that properly, I would be very grateful.

Thank you for your help!

regards,
kao
kao
 
Posts: 3
Joined: Sep 13 17 7:42 pm

Re: How to set up proxy server properly

Postby MattP » Sep 13 17 9:04 pm

Hi,

Are you setting the proxy up for home or an office network? What is the reason that you're wanting to use a proxy?

How many network cards do you have in your computer? In the screenshot you've posted, it shows that you have bound your SOCKS proxy to your external adapter. This is not ideal as it means that anonymous users on the Internet can connect to your proxy, this is known as being an open proxy, and is not a good thing. You should remove the binding policy that binds the 213.197.169.94 adapter to the proxy immediately, and we can continue to help you get set up.

I would guess that you're not able to set up a WWW proxy because something is already running on port 80. Try changing the service port in the WWW proxy service properties to something else, e.g. 8080.

Regards,

Matt
MattP
Qbik Staff
 
Posts: 977
Joined: Sep 08 03 4:30 pm

Re: How to set up proxy server properly

Postby kao » Sep 13 17 11:03 pm

MattP wrote:Hi,

Are you setting the proxy up for home or an office network? What is the reason that you're wanting to use a proxy?

How many network cards do you have in your computer? In the screenshot you've posted, it shows that you have bound your SOCKS proxy to your external adapter. This is not ideal as it means that anonymous users on the Internet can connect to your proxy, this is known as being an open proxy, and is not a good thing. You should remove the binding policy that binds the 213.197.169.94 adapter to the proxy immediately, and we can continue to help you get set up.

I would guess that you're not able to set up a WWW proxy because something is already running on port 80. Try changing the service port in the WWW proxy service properties to something else, e.g. 8080.

Regards,

Matt


Thank you very much for your quick and informative answer!
I will try to reply as much as I can, but I am not very technical advanced so my knowledge may be limited.

1) 'Are you setting the proxy up for home or an office network? What is the reason that you're wanting to use a proxy?' - I guess I am setting it for my home network, as I bought VPS and set up that VPS as a proxy server. The reason for that is that I need to connect to certain websites under different IP than mine and those websites CANNOT know that I am using a proxy.

2) How many network cards do you have in your computer? - well this is the question that goes beyond my knowledge. I am using a standard laptop so I guess it's the standard number of those network cards.

3) In the screenshot you've posted, it shows that you have bound your SOCKS proxy to your external adapter. This is not ideal as it means that anonymous users on the Internet can connect to your proxy, this is known as being an open proxy, and is not a good thing. You should remove the binding policy that binds the 213.197.169.94 adapter to the proxy immediately, and we can continue to help you get set up. - I did it as you requested. The reason why I did this, because this was the only way I could find to set up a proxy. So these are the default settings for SOCKS proxy, how do I configure them?

Image
kao
 
Posts: 3
Joined: Sep 13 17 7:42 pm

Re: How to set up proxy server properly

Postby kao » Sep 15 17 2:02 am

Can someone help me with this, please?
kao
 
Posts: 3
Joined: Sep 13 17 7:42 pm


Return to WinGate

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron