Wingate Reverse Proxy Function

Use this forum to post questions relating to WinGate, feature requests, technical or configuration problems

Moderator: Qbik Staff

Wingate Reverse Proxy Function

Postby IT-Works » Jul 24 18 5:46 am

Hello,
I have been evaluating Wingate for our company as a Reverse Proxy server; However, every 48 hours or so I have to reboot the server to make it function. It seems promising for what I like to accomplish but this apparent instability is causing setbacks for me. Can you help with some diagnostics? here is what the system is

- Wingate Evaluation license 9.2.0.5975
- Single NIC ( I like to forward only certain traffic from Firewall to certain webservers )
- Server OS is Windows 2012 R2 running on ESXi 6.0.0
- VMware tools are installed.
- Server RAM is 8GB of which only some 10% is used at idle.

I have done the following under Wingate Advanced options:

- increased Max Network Buffers to 32768
-Pre-allocate Hash Entries 512
Everything else is default.

- I setup a test re-direct that normally should show "Request Denied", but then I get "no response" after leaving the server for a 48 hours or so. Any help is appreciated.

Regards
SN
IT-Works
 
Posts: 3
Joined: Jul 24 18 5:24 am

Re: Wingate Reverse Proxy Function

Postby adrien » Jul 24 18 11:33 am

Hi

how many cores do you have assigned to the VM? I'd suggest normally minimum 4 (even though it may show CPU usage to be very low, it affects concurrency which impacts latency a lot).

Also I'd suggest testing the other network adapter, I presume you're using the vmx3net driver? Some people have more luck with the E1000 drivers.

Finally if you don't need NAT or connection interception (which you don't need for reverse proxy) then I'd suggest removing the WinGate Network Driver (NIC properties in OS, select the driver and choose uninstall, then reboot).

Regards

Adrien
adrien
Qbik Staff
 
Posts: 5245
Joined: Sep 03 03 2:54 pm
Location: Auckland

Re: Wingate Reverse Proxy Function

Postby IT-Works » Jul 25 18 7:37 am

Thank you , I will try those steps and post back with results.
IT-Works
 
Posts: 3
Joined: Jul 24 18 5:24 am

Re: Wingate Reverse Proxy Function

Postby IT-Works » Aug 04 18 6:04 am

Update:
I have switched the NIC from E1000E to E1000 and for past few days the system has been stable. I also modified cores to 2x2 . Thanks for your help.
IT-Works
 
Posts: 3
Joined: Jul 24 18 5:24 am


Return to WinGate

Who is online

Users browsing this forum: adrien, Bing [Bot] and 3 guests