Problem installing Wingate on Windows 10

Use this forum to post questions relating to WinGate, feature requests, technical or configuration problems

Moderator: Qbik Staff

Problem installing Wingate on Windows 10

Postby GTarr » Jul 02 21 9:54 am

Hi All,

I am trying to install Wingate on my Windows 10 laptop. The version of Wingate is 9.4.1.5998. After the install completes, the icon in the tool try shows the
the service is running. I then start the Management Console and select the Local Host to connect. The icon in the upper left cornor of the Managment Console spin around for about 10 seconds and the I get a popup that states "Connection with Wingate Server Terminated". What am I doing wrong?

Thanks
Gary
GTarr
 
Posts: 4
Joined: Jul 02 21 9:30 am

Re: Problem installing Wingate on Windows 10

Postby adrien » Jul 02 21 10:51 am

Hi

this is usually because some other service in your computer is running on the port that WinGate Management is expecting WinGate to be running on for remote admin.

This is port 808.

The usual culprit is the .NET port sharing service. Usually this can be stopped without any implication. If it's not that service, you can perhaps see what service is running on port 808 from the command line by typing

netstat -ano -p tcp

This will list all TCP endpoints in your system and the PID (process ID) of the process running it. You can then open task manager (Ctrl-Shift-Esc) and on the Details tab you will see the PID of all the running apps. This will show you which app is listening on port 808.

If you don't need this service / app you can stop it, and then restart WinGate.

Alternatively you can get WinGate Remote Control Service to run on a different port, but without access to WinGate console you need to edit the registry.

1. Stop WinGate service
2. Open Regedit.exe
3. navigate to HKEY_LOCAL_MACHINE\Software\Qbik Software\WinGate\Services\Remote Control Service
4. edit the value called "PortNumber" and set it to a new value. Be sure to select "Decimal".
5. Start WinGate service again
6. Open WinGate Console, and in the connection tile for localhost, edit it (hover and click on the pencil icon) and change it to localhost:portnumber (where portnumber is the port number you chose in step 4. e.g. localhost:809

You should then be able to connect ok.

Regards

Adrien de Croy
adrien
Qbik Staff
 
Posts: 5412
Joined: Sep 03 03 2:54 pm
Location: Auckland

Re: Problem installing Wingate on Windows 10

Postby GTarr » Jul 02 21 2:14 pm

Thanks, that resolved my issue.

Gar
GTarr
 
Posts: 4
Joined: Jul 02 21 9:30 am


Return to WinGate

Who is online

Users browsing this forum: Bing [Bot] and 4 guests