Switch to full style
Use this forum to post questions relating to WinGate, feature requests, technical or configuration problems
Post a reply

Host not found

Aug 21 21 10:38 pm

I'm getting "name lookup failed" when trying to access the HTTP server (which is the wingate computer) by name. Connecting via ip address works. If I disable the proxy setting in the web browser it works.
Adding entries to the hosts text file allows the ability to use the proxy server.


Re: Host not found

Aug 23 21 1:52 pm


If your client computer is using a proxy, then the proxy will do the DNS lookup.

So it sounds like WinGate's DNS client is having trouble resolving the hostname of the WinGate computer.

Since WinGate uses its own DNS resolver (client), the configuration of the client can be different to the host computer.

Is this an AD? Are you using fully-qualified names when you try to connect?

If not, you may need to add the local domain suffix in the DNS client in WinGate, and make sure there's a server entry pointing to your AD DNS server for that domain.

Re: Host not found

Aug 23 21 4:22 pm

Hi Adrein,

It's a Windows 10 Pro computer. The strange thing is that the browser can't find the computer it is on (also clients can't find that computer either). No client software installed - just use the settings in the browser. The client computers are either Windows Pro OEM UK or Windows 10 home. No AD.
Host computer: tower-asus
Client computer: laptop-cer
I was getting the error when using tower-asus to connect to tower-asus.
Same with laptop-acer (and the others) connecting to tower-asus.

The solutions I have used to get around this is to
use script: if isPlainHostName then direct
use exclusion if manual proxy configured
Add entries to the host file on tower-asus - this has meant my phone and tablet now works and I don't need the above 2 configurations (Android didn't work with script, nor provision for exclusions).
I understand that the proxy does the DNS lookup but don't know why it can't find itself. Since Wingate uses the hosts file (probably as a last resort) I added the entries there.

Re: Host not found

Aug 24 21 2:06 pm

This my be related: The DNS server log shows:
Socket exception in CDNSService::OnRead Connection Reset by Remote Host
Which is appearing several times a minute

Re: Host not found

Aug 24 21 3:04 pm


There are 2 components in WinGate to do with DNS.

1. The DNS client. This is used to look up names in other DNS servers. By default it uses the same DNS servers that your underlying Windows installation is using.

2. The DNS server. This is an optional service in WinGate, and if you install it, it is used by other DNS clients on your network to look up names.

As for looking up a machine by its name, this can have 2 mechanisms, and I wonder if it's using the second one.

1. DNS lookup to an AD DNS server.
2. NetBT broadcast lookup on the local network.

WinGate itself periodically queries the network using NetBT (which is basically DNS over a different port).

As for that error report, that would happen if the DNS server tried to respond to a query, and when it sent the response back (this is the only time the DNS server actually performs a send) the client DNS resolver had closed the socket.

DNS clients are used for all lookups, including by the DNS server, so the only thing that sends a query packet (does a lookup) is the DNS client. The only time the DNS server sends is for responses back to clients.

Re: Host not found

Aug 24 21 3:05 pm

Since you don't have any local DNS service that learns about your local machines (this is what an AD DNS server would do), then the hosts file on the WinGate computer is actually a good option.

Re: Host not found

Aug 24 21 3:22 pm

Thanks Adrien,
I do have Wingate service installed. Looks like the host file is the way to go. I use the DHCP server to use reserved addresses - the permanent computers/DVR of the LAN.

Re: Host not found

Aug 24 21 3:52 pm

OK. Any host registered to WinGate's DHCP should show up in WinGate's DNS, but the WinGate server itself won't be doing that.
Post a reply