Visnetic plug-in shows old AV def update date

Forum for support for the Kaspersky AntiVirus for WinGate plugin

Moderator: Qbik Staff

Visnetic plug-in shows old AV def update date

Postby saubrey » Mar 02 04 6:17 pm

The Visnet plug-in, when viewed thru GateFilter shows an 5 day old date (Feb 25) for last AV definition update. Yet the Visnetic update scheduler program shows today's date (Mar. 1) as the AV def update date. I'm using Wingate 5.2.2 and Visnetic 4.4.3.1. I have stopped and restarted the Wingate engine and also existed and restarted Gatefilter and yet Gatefilter still shows Feb 25 as the last AV def update date. How do I force Gatefilter to show and *use* the latest AV definition updates? Thanks, Steve
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby Pascal » Mar 02 04 11:45 pm

Is everything showing up, properly licensed and so on ? The stop/start of the Engine would be the extreme case to refresh the update information. Normally, you only need to have an AV interface created, and GateKeeper opened and closed.

Can you send me the file date/time of PluginDKAV.dll ? (Should be in C:\Program Files\WinGate\Plugins\AntiVirus for WinGate)
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby saubrey » Mar 03 04 4:49 pm

Gatekeep shows License expires 29 Sep 2004. Which is correct.

PluginDKAV.dll has date/time stamp of 12/11/2003
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby Pascal » Mar 03 04 5:01 pm

That's the correct date/time, I believe. I'm very curious now, because a restart of WG should definately pick up on the correct information for this.

WG uses the date/time (string format) supplied from the underlying subsystem, so it is interesting that the two different accessors to that subsystem are given different dates/times.

It's not going to be helpful, but does a reboot of the machine make any different to the date/time reported ?
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby saubrey » Mar 03 04 6:59 pm

After re-booting the Win2k server and restarting Wingate and GateKeeper, GateKeeper AV plug-in now shows 2004/03/03 as the last Update of AV definitions. 2004/03/03 is also the date shown in the Visnetic Update Scheduler program...so for now Gatekeeper and the Visnetic Update Scheduler are in agreement for the last update date. However, just to be clear, prior to rebooting the win2k server, GateKeeper was showing 2004/02/25 as the last update date...which was one week out-of-date from Visnetic Update Scheduler. I have seen this behavior before with 5.2.X and 4.4.3.1 where Gatekeeper's last update date is older than Visnetic's. Any idea how to fix this?
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby saubrey » Mar 06 04 5:35 am

Pascal: Do you have advice for fixing this issue?
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby Pascal » Mar 06 04 8:12 pm

According to the code and all our tests, the date should be updated whenever a new interface (Scanning interface) is created. The view in GateKeeper will be refreshed whenever the data is sent across the link (In other words, when GateKeeper comes online)

The underlying AV engine is told to automatically reload it's databases, so it should be doing that, and your file date/time indicate that you have the latest version.

About the only thing I can think of is sending you a debug kit, which I'll be able to do Monday.
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby saubrey » Mar 07 04 5:20 am

Three more pieces of info.
1. It has now been three days since I rebooted the Wingate server and GateKeeper is correctly showing the up-to-date AV def info. I've seen this behavior before where GateKeeper shows up-to-date AV def. info for a while, like a week or two, then for some reason it eventually gets stuck showing the same old date even though the Visnetic update scheduler shows a more recent date.
2. DKavupsch leaks Windows handles(as shown by Task Manager)...after three days DKAVupsch is consuming 57,000 handles. Could this leak cause GateKeeper to stop showing the updated AV defs after a week or two of running? Leaking approx 20,000 per day, after two weeks it will have leaked over 250K handles.
3. I always access the Wingate computer remotely through Terminal Services Client. And I then run GateFilter through Terminal Services client. Could the problem that I'm having be due to some conflict with Terminal Services Client? I seem to remember that prior versions of Wingate/Gatekeeper seemed to have some problems with TSC.

One more thing...if you think that updating to Kaspersky AV will fix this issue I will do so eventhough I have 6 months remaining on my one year subscription to Visnetic. The amount of time I have spent on this issue (and you too) far outweighs the cost of upgrading

Thanks for your help.
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby Pascal » Mar 09 04 9:33 am

How frequently do you see this problem ? I think what we should do is wait until it happens again, then get a snapshot from Task Manager or something similar, so we can try and figure out why.
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby saubrey » Mar 09 04 5:27 pm

I'd rather upgrade if you think that upgrading will fix this. Waiting until it happens again is more work for me and potentially leaves my server vunerable when its AV defs are out of date. Will upgrading to Kapersky fix this issue?
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby Pascal » Mar 09 04 5:37 pm

We use Kaspersky AntiVirus for WinGate here, to protect our own network. The last update date is shown as 7 March, 2004. I believe it is currently set to update once every 3 days. (Original default).

We've not had any problems with it, but by the same token, we were running VisNetic AntiVirus before that and it was the same - we never experienced any problems.

I am wondering if that handle leak you are seeing could not be part of the problem. Have you asked Deerfield if they have that listed as a known issue ?
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby saubrey » Mar 10 04 5:04 pm

Regarding the handle leak...Deerfield pointed the finger back at Qbik saying that it is a known problem, but not their fault and they can't fix it. They said that Qbik changed the interface slightly after Visnetic 4.3.3.1 was released which is now causing the Visnetic program to leak handles.
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby Pascal » Mar 10 04 5:12 pm

"DKavupsch leaks Windows handles(as shown by Task Manager)...after three days DKAVupsch is consuming 57,000 handles"

Are the handles reported against DKavUpsch.exe ? As far as I can tell from our source code, we never interact with DKavUpsch.exe. Our QA team will investigate that though.
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby saubrey » Mar 10 04 5:17 pm

Yes, the handle leak is against DKavupsch.exe

I just now attempted to cross-upgrade to Kaspersky using the Wingate web site and got the following error after entering my current visnetic license key and license name:

Fatal error: Call to a member function on a non-object in D:\Inetpub\wwwroot\wingate_com\upgradeitem.php on line 153

Can you tell me how to successfully cross-upgrade? Thanks, Steve
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm

Postby Pascal » Mar 11 04 12:08 pm

I ran an older license key through the system from here and home, and in both cases it went through right to the point where I'd actually have had to pay.

Where was it failing for you ? If you're still experiencing problems, you can contact support directly (Via a support ticket) they can help with licensing issues, and so on.
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby saubrey » Mar 12 04 6:40 pm

I have successfully cross-upgraded to Kaspersky and it has been running successfully for 1.5 day. Thanks for your help.
saubrey
WinGate Master
 
Posts: 207
Joined: Sep 15 03 12:55 pm


Return to Kaspersky AntiVirus for WinGate

Who is online

Users browsing this forum: No registered users and 1 guest

cron