AntiVirus not working

Forum for support for the Kaspersky AntiVirus for WinGate plugin

Moderator: Qbik Staff

AntiVirus not working

Postby GeneE » Mar 27 04 9:46 am

I just installed the Trial Kaspersky antivirus last week for my wingate upgrade and removed the visnetic av. I then updated the definitions for the kav and set it to update daily. Sometime in the last week 2 of my computers have been infected with the w32.beagle and w32.netsky. at this point it looks like i would be wasting my money buying the Kaspersky!!!

Any ideas or help would be appreciated if I am doing something wrong in wingate and it is passing by the AV completely.
GeneE
 
Posts: 12
Joined: Mar 26 04 11:06 am

Postby GeneE » Mar 30 04 2:35 am

well, i came into work this morning and it appears that Kaspersky is keeping me from sending out any infected emails, but still letting them in.
GeneE
 
Posts: 12
Joined: Mar 26 04 11:06 am

Postby Pascal » Mar 30 04 2:27 pm

How is mail coming in to your network - are you using WinGate's mail server ? Double check that you have the Kaspersky Plugin enabled in all the right places, then also check the options you have specified in the plugin itself.
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby GeneE » Mar 31 04 2:42 am

I still have not received the help file from your support office, so evidently I dont have it configured correctly yet. I have retrained my staff, again, to not open any email attachments until i have approved them...have those banned in OE, however would like to have everything up and running correctly.

Again, the person who set up wingate and the antivirus is no longer employed here, and I have nothing to help me set up either or to double check the mess he has left me.

Thanks for your help concerning this.
GeneE
 
Posts: 12
Joined: Mar 26 04 11:06 am

Postby Pascal » Mar 31 04 10:53 am

Verify State of Plugin
Open GateKeeper.
Go to the Plugins button.
Look for an entry called "Kaspersky AntiVirus".
Does it have any message next to it's name ? (License invalid, etc.)

Check Plugin Options
Open Kaspersky AntiVirus.
Go to the second tab, and check that all the options at the bottom are checked.
Verify that on the Allow list there is not an entry that will allow everything through.

Check settings in GateKeeper
Go to the SMTP Server (Services tab)
Switch to the Plugins tab in there
Check that Kaspersky AntiVirus is listed there and is enabled
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby GeneE » Mar 31 04 12:18 pm

Plugin state is valid - Trial license - status was listed as "ready"

Kasp Plugin Options - All lowers are and had already been checked, did not find any "Allow" list.

Gatekeeper SMTP Server - Kasp was checked and listed there.

Received another email this afternoon, after I had double checked these items, about 20 minutes ago which had the w32.beagle and w32.netsky on it. Kasp did not detect them (only reason I know it had them is I forwarded the message to my personal computer where Norton AV found and erradicated it. I then did a manual delete of this file from the companys' computer OE.

I'm at a total loss at this point. If you have any setup documentation for setting up wingate and kaspersky or how others have set it up so I can double check all settings throughout, it would be greatly appreciated.
GeneE
 
Posts: 12
Joined: Mar 26 04 11:06 am

Postby Pascal » Mar 31 04 12:25 pm

We're just getting a mail setup document ready. Once that is done (Sometime today) I'll send you a link to it. That would be the next step to check then, because it seems as if Kaspersky is all configured properly. (In the interim, you can ensure that it has the latest AV definitions by running the updater - either by clicking the "Update" button in the plugin dialog in GateKeeper, or by running the manual updater from the Start Menu)
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby Pascal » Mar 31 04 5:11 pm

http://www.wingate.com/files/Mail_Server_Scenarios.pdf

That is the basic mail server setup guide. The idea behind this is to work out how mail is coming in to your machines, to see where KAV should be configured, etc.

So, going through that, can you determine what scenario matches your setup, please ?
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby GeneE » Apr 01 04 3:19 am

This looks like it will cure my problem. Will post back after implementation and rain some praise on you. =)
GeneE
 
Posts: 12
Joined: Mar 26 04 11:06 am

Postby Pascal » Apr 01 04 10:31 am

Neil's the one deserving praise. He wrote the document :-)

Good luck !
Pascal

Qbik New Zealand
pascalv@qbik.com
http://www.qbik.com
Pascal
Qbik Staff
 
Posts: 2623
Joined: Sep 08 03 8:19 pm
Location: Auckland, New Zealand

Postby GeneE » Apr 02 04 3:57 am

Well, seems to have fixed it, lol, I'm not receiving any mail now whatsoever...sigh, considering starting over from scratch and walking thru step by step to make absolutely sure one of his previous settings isn't affecting what im attempting to do.
GeneE
 
Posts: 12
Joined: Mar 26 04 11:06 am


Return to Kaspersky AntiVirus for WinGate

Who is online

Users browsing this forum: No registered users and 1 guest

cron