KPAV 8.0.0 not running under WinGate 8.0.1 on Win7-64

Forum for support for the Kaspersky AntiVirus for WinGate plugin

Moderator: Qbik Staff

KPAV 8.0.0 not running under WinGate 8.0.1 on Win7-64

Postby Thomas Illies » Sep 25 13 9:13 pm

We want to change our WinGate PC from XP-SP3 to Win7-64.

Both machines are running WinGate 8.01, Kaspersky Antivirus 8.0.0 and SMS Connector 8.0.0.

I imported the 32bit-settings to the 64bit machine successfully (still using the trial licenses).

The Kaspersky plugin is not started, and the log looks like

#Software: WinGate Format Id: {87E28D6E-308D-4799-81D7-DF2272774030} Format Name: WinGate Logger Format
#Version: 2.0 FieldMask: 1023
#Fields: SeqNo DateTime IP User LogSource ThreadId Context Severity EventId LogText
#Remark: TimeZone: -1:00
3 25.09.2013 09:47:30.069 Kaspersky AV for WinGate 1868 error 0 Loading Updater SDK failed, base path C:\Program Files\WinGate7\Packages\Kaspersky AV\Bin
4 25.09.2013 09:47:30.069 Kaspersky AV for WinGate 1868 error 0 Loading SDK failed, base path C:\Program Files\WinGate7\Packages\Kaspersky AV\Bin, error 126

Under C:\Program Files\ there are the directories ..\Wingate and \Wingate7 as well...

Has anyone an idea how to fix this ?
Moving the ..\Wingate7\ contents to ..\Wingate directory and modifying the registry settings to match that direcory ?

Best regards

Thomas
Thomas Illies
 
Posts: 5
Joined: Oct 09 12 2:20 am
Location: Hamburg

Re: KPAV 8.0.0 not running under WinGate 8.0.1 on Win7-64

Postby adrien » Sep 25 13 11:52 pm

Hi

did the program files folder change from c:\program files to c:\program files (x86) ?

This is most likely the problem - importing old settings can overwrite paths that are needed and are slightly different between x64 and x32 OS.

Regards

Adrien
adrien
Qbik Staff
 
Posts: 5191
Joined: Sep 03 03 2:54 pm
Location: Auckland

Re: KPAV 8.0.0 not running under WinGate 8.0.1 on Win7-64

Postby Thomas Illies » Sep 26 13 2:25 am

Hi Adrien,

thanks for your hints !

We had a mixup of installation files under C:\Program Files\ and under C:\Program Files (x86), with many of the registry entries pointing to the wrong directory.
After merging the directories from C:\Program Files to C:\Program Files (x86) and after editing all registry entries to the proper directory anything works fine !!!

Thanks again for the quick help !

Thomas
Thomas Illies
 
Posts: 5
Joined: Oct 09 12 2:20 am
Location: Hamburg

Re: KPAV 8.0.0 not running under WinGate 8.0.1 on Win7-64

Postby adrien » Sep 26 13 2:36 pm

You're welcome!

glad you got it working.

Regards

Adrien
adrien
Qbik Staff
 
Posts: 5191
Joined: Sep 03 03 2:54 pm
Location: Auckland


Return to Kaspersky AntiVirus for WinGate

Who is online

Users browsing this forum: No registered users and 1 guest

cron