Set up https inspection to log full urls

Use this forum to post questions relating to WinGate, feature requests, technical or configuration problems

Moderator: Qbik Staff

Set up https inspection to log full urls

Postby username » May 24 19 5:37 am

Hello,

I am trying to set up https inspection to log full URLs of internet traffic. I am using the trial of enterprise edition. I think I have missed an important step here. I have done:

1. Created Signed Certificate
2. Deployed signed certificate to client and flagged it as trusted. This seems to be working, it lists as "verified" on the client
3. Set up the default www proxy server to use the signed certificate under SSL inspection (default settings)
4. Client is set up to have its gateway pointing to the wingate proxy server.

It almost works, records traffic of base root URL, but does not record full URLs. Wingate documentation says I need to configure the client to use the proxy server. However, on the iPad (client device), if I set "HTTP PROXY" under the wifi settings to point to the ip address of the wingate server, web pages no longer load, with error "server cannot be found". Browser is Safari. I have tried "Auto" settings for proxy server, as well as "manual" with port 80 or 443, with or without authentication (I don't even know what user name I would use?)

What step am I missing here? Are my client settings incorrect? Or is there something on Wingate I have not yet set up to handle the proxy request from the client?
Thanks so much.
username
 
Posts: 1
Joined: May 24 19 5:26 am

Re: Set up https inspection to log full urls

Postby Thomas » Dec 10 20 6:50 am

Hey username,

Did you ever figure this out? I was needing to do the same thing if you'd found a resolution.

-Thomas
Thomas
 
Posts: 1
Joined: Dec 10 20 6:48 am

Re: Set up https inspection to log full urls

Postby adrien » Jan 06 21 5:50 pm

Hi

how did you specify the proxy in the iPad? Unfortunately we've found iOS to be notoriously unreliable when it comes to using a proxy (some apps ignore it).

It's possible it's complaining about not being able to find the proxy. Because when using a proxy the client shouldn't need to do DNS resolution to resolve the host.

But it is possible to intercept https to the proxy (e.g. client set just to use gateway), but you need on the interception tab in the WWW Proxy to set to intercept also port 443.

Regards

Adrien de Croy
adrien
Qbik Staff
 
Posts: 5406
Joined: Sep 03 03 2:54 pm
Location: Auckland


Return to WinGate

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron